AXForum  
Вернуться   AXForum > Microsoft Dynamics NAV > NAV: Программирование
NAV
Забыли пароль?
Зарегистрироваться Правила Справка Пользователи Сообщения за день Поиск Все разделы прочитаны

 
 
Опции темы Поиск в этой теме Опции просмотра
Старый 30.05.2013, 22:30   #1  
alexb_imported is offline
alexb_imported
Участник
 
256 / 12 (1) ++
Регистрация: 25.08.2006
NAV 2013: в отчёте не печатаются текстовые поля в Header'e в NOT PREVIEW-модусе
Есть отчёт (как custom-копия Report 204). Если печатать отчёт в preview то всё ОК, если послать напрямую на печать на принтер
то в отчёте не печатаются текстовые поля в Header'e, т.е. вместо них просто пустое место. Строки (Sales Line's) печатаются как обычно. В Expression всех текст. полей в Header прописана GetData()-функция, в свойстве Hidden стоит везде FALSE, короче всё вроде как и в стандартном R.204.
Весь программный код с использованием CurrReport.PREVIEW в отчёте убрал, не помогло. Добавил свой тестовый текст-бокс в Header с Expression=TODAY и этот текст-бокс печатается, всё остальное - попрежнему нет.
Подозреваю что что-то не так с управлением GetData()-функции в связке с посылкой напрамую на печать (NOT PREVIEW), но не пойму что.
Есть у кого-нибудь идеи?
 

Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск
Опции просмотра

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.
Быстрый переход

Рейтинг@Mail.ru
Часовой пояс GMT +3, время: 19:57.
Powered by vBulletin® v3.8.5. Перевод: zCarot
Контактная информация, Реклама.